Guild level adjustment not working

Like all guilds, we are trying to recruit. We were set at level 60 on server 9 but want to lower to level 30. Now it did work earlier in the week but now all of a sudden, it won’t take hold and says our guild has not earned that emblem yet. Several of us have tried but it keeps going back to level 60.

Any ideas?

You should be able to do it

1 Like

The default emblems (under the default tab) are glitched in that nearly all of them are missing. Only Sticky Spell Book and Thunk Trunk are there; if you’re using a default emblem that is not one of them then you will be unable to update your guild.

If you want to update your guild, then you’ll have to change your emblem to an emblem rewarded from PL or one of the emblems I listed above.

2 Likes

Ok, that worked. I am not sure of one of our members changed of or it did it on it’s own but now it’s working. Thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.