"Invalid loot" I cannot advance in campaign

I’m asking for any help or advice from staff. I think my game is glitched. I completed the same campaign level 3 times with 3 stars and is throwing me back to the same level, without letting me to advance. The error message is down here. :arrow_down:

Also, i restarted the game and reinstalled it after but all of these with no result.
I hope it will not take too long to be resolved. The Contest is active and i’m losing points. Thanks in advance.

When I get that I go back to the home screen and try again. Usually works

i tried everything, i’m stuck with almost 7k stamina and I can’t advance in contest points…

Restart device, helps for me?

i did, trust me…

This may sound crazy but it seems like you’ve tried everything else

Change your location? If you’re running in WiFi try a different WiFi or try switching to data.
Even if it seems like the connection can’t possibly be the problem, it can’t hurt to try.

Have you tried another device?

Clear app cache? If not, uninstall and reinstall game?

PerBlue Entertainment | Terms of Use | Cookie Policy